Modifying Label Designs in EzyNest.

Modifying Label Designs in EzyNest.

Modifying EzyNest Label Designs

Note: Throughout this document we will be referring to the program as EzyNest, but the exact same steps apply to EnRoute.
Opening label designer:


In EzyNest 6, you can access the label designer application directly from within EzyNest. This can be done by clicking and holding the mouse button on the ATP button in the toolbar, then selecting the label designer.

In EzyNest 5 or earlier, you will need to open the label designer application directly from the windows file explorer.

This is found in the EzyNest folder, typically located in C:\AllMasterSoftware\EzyNest5\AutoTP\Labels\LabelDesigner.exe

Editing label designs

Opening a label design:

Once you open the label designer, you will first want to maximise the application. This will make it far easier to modify the label design once it is opened.



Then after you open the label design you want to modify (File -> Open) , edit the properties of the grid to a smaller increment such as 1mm or 0.5mm (Edit -> Properties -> Grid). This will make it easier to see the bounding box of the text fields, images etc on the label.

Modifying label size and name:

If you need to adjust the size of the label, or the name of the label design, this can be done in the design properties of the label. (Edit -> Properties -> Design) .

Keep in mind if you are making the label design smaller, some objects on the edge of the label may no longer fit on the label design. To avoid this, it is best to move everything on the design away from the edge before reducing the label size.


NOTE: The name specified in the design properties is not automatically the same as the file name of the label design. This label design name is referred to in some other aspects of the label settings in EzyNest, so the best practice is to set this design name the same as the label design’s file name.

Adding static images or text:

There are three tools to add information to your label designs. These are the Text Tool, Barcode Tool and the Picture Tool.

Most of the label design will be made using either the text or picture tool.



To place a text field or picture on the label design, simply click on the tool to select it, then click and drag on the space you want it to occupy on the label design.

You will then be able to modify the object properties to enter the text you want to display or import an image (eg company logo).

You can also modify the properties of any existing text or image objects on the label by double clicking on them with the select tool.

If you want to add a dynamic text field that will be filled in with information from your drawing (eg part sizes etc), see the ‘ adding placeholder fields’ section of this document.



Adding placeholder fields:

In a production environment, many of the text fields will need to contain different information for each part or drawing (eg part measurements, job number, etc).

This can be achieved by using placeholders.

When placing or editing an object, you can assign the object as a placeholder in the ‘Data’ tab. You can then select which information it will be replaced by in the data source field drop-down list.

Eg. If you want to display the width of the part, select the ‘Width’ from the data source list. This will then replace the text field you placed with the actual width of the part when the label is generated.



When looking at the existing label design you can see which objects are placeholders and which are static by checking whether the object has blue arrows in the top left corner.

If these blue arrows are present, that object is then acting as a placeholder, and will be replaced by the information from the drawing.

If the arrows are not present, the text or image will remain static and will print exactly as shown on the label design.



You can also check which data source is being used by opening the object properties (double clicking on it with the select tool) and checking the Data tab.

Adding New Data Sources

In some cases, there may be certain job information you want as a placeholder on the labels that is not available as a preconfigured data source.

In order for the data to be available in the label designs, the information needs to be present in both the exported files that are processed through EzyNest, as well as the label data configuration file from the label designer itself.

The first step is to make sure the information you want to show on the labels is included in the ‘dxt’ list file that is exported from your CabMaster Software program (eg CabMaster, DoorMaster, ShapeMaster etc.)

This is the file that includes all the information for the job and each part as it is processed through EzyNest to create your labels and output files.

The examples shown below will show the process for adding a data field from CabMaster, but the process for adding information from DoorMaster and ShapeMaster is practically identical.

Adding the data to the dxt list file:

In order to add any new data fields to the exported machining files, you will need to adjust the LabelXMLExtras.txt file in the Library folder of your
program’s installed location.

This can be found from within the program by going to File -> Options and copying the libraries file location into the windows file explorer.



The labelXMLExtras.txt file will have a list of preconfigured data fields, to add a new one you will just need to make a new entry at the bottom of the file. The text file is in a tab separated format , this means that you will need to press the tab key between each column for it to read the data correctly when exporting.

The structure of the file is as follows:

Exported name  <tab>  Data type (this is usually ‘Text’)  <tab>  Variable from program

For example, if you wanted to add the Account Name from CabMaster, you can hover over the text field from within the program and it will tell you what the variable name is.



Then you will just need to add that variable into the LabelXMLExtras.txt file, as shown below:



Make sure you separate the three columns with tabs, or it will not export correctly.

You can then check if this exported correctly by restarting the program, then exporting a file and opening the exported dxt file (Usually found in C:\Machining\ drawing name \ Material name\ )



The dxt should now show the custom field you entered into the LabelXMLExtras.txt.

Adding the data to the Label Data Configuration:

Once the information you want to add to the label is present in the dxt file, all that's left to do is to add a reference to this new field in the Label Data Configuration within the label designer. This can be done from within the label designer application when assigning a placeholder.

To add a new data source, go to the object properties like you usually would when adding a placeholder, then in the ‘ Data ’ tab, select the ‘ Edit source field list ’ button.

This will then pop up with a ‘ Field List Editor ’ window which will allow you to add or remove any data fields from your data source list.



All you need to do to add your new data source is type the name of the field as shown in the dxt file and click ‘Add’.


Once you have added the new entry list editor, you should be able to assign that value as a placeholder in the label designer.

NOTE: The field name you enter into the field list editor must exactly match the entry you made in the LabelXMLextras.txt file, bearing in mind the case as well as any separator or special characters (eg spaces etc.)
TIP: Click the attachment to download this HowTo to your desktop as a .pdf
    • Related Articles

    • Understanding the EzyNest ATP

      Understanding the ATP The ATP (“Automatic Tool Path”) is certainly the simplest method for nesting in EzyNest. Accessed by pressing the ATP Setup button  on the toolbar, it allows you to import files that have been created by exporting machining ...
    • Understanding the EzyNest/EnRoute Design Depth in the ATP

      Inside EzyNest there is the Automatic Toolpath (ATP) which is used to process jobs from CabMaster. It is recommended in the 'Define Layers' tab that you setup your strategies to have the correct 'Design Depth',  with the 'Use Depth' is ticket on ...
    • Importing Data into CabMaster Software

      Attached is a simple Excel file that could be used to try this. Importing Data into CabMaster Products CabMaster and its associated products have the ability to import a wide variety data directly to the program, in this document we will outline how ...
    • Customising a cabinet in CabMaster Software

      Customise a Cabinet Cabinets can be customised before or after they are placed on the drawing. For comprehensive discussions see also the following: CabMasterPro Help topics [F1] : Topic Discusses Cabinet Properties Different ways to select cabinets ...
    • Formatting Dimension Labels

      Format Dimension Label On every dimension line you use, a label is placed along it showing how long that section of the line is. These labels do not usually show units, ie the label on a 42.67 cm dimension would just be "426.7" (depending on the ...